Compatibility


F3 is intentionally stuck with strong backwards compatibility to OpenERP 6.0

This is intentional. We believe that an ERP must have a long API "maturity" phase, where the ecosystem can enjoy a stable, supported platform.

The 6.0 API is not perfect, we acknowledge that. But still, many of the syntactic shortcomings are a matter of programming taste, that an experienced developer can learn to live with.

One case where F3 API does break compatibility is formerly gray-areas of the 6.0 API, that also left much space for bugs. For example, osv.memory fields that were marked as "required", but never enforced that restriction.

Follow us